Back to overview
Resolved
Dashboard and sandbox outage
Sep 16, 2026 at 6:29pm UTC
Affected services
Deployment
Sandboxes
Dashboard
Resolved
Sep 16, 2026 at 6:43pm UTC
We're observing recovery of impacted services and will continue to monitor.
Affected services
Updated
Sep 16, 2026 at 6:39pm UTC
We've identified the source of the issue and remediated.
Affected services
Created
Sep 16, 2026 at 6:29pm UTC
We're currently tracking an outage for our customer dashboard and sandboxes. We will update as we have more information.
Affected services