Internal data stores are failing
Resolved
May 8, 2026 at 2:30am UTC
All services except queues have recovered. Queues are currently seeing recovery, and fully recovered as of 11:50pm EDT.
Affected services
Updated
May 8, 2026 at 2:30am UTC
All data stores are recovered
Affected services
Updated
May 8, 2026 at 1:12am UTC
We are continuing to work toward mitigation and will share updates as we have them
Affected services
Updated
May 8, 2026 at 12:40am UTC
AWS us-east-1 EC2 is currently experiencing an outage, affecting our internal data stores
Affected services
Created
May 8, 2026 at 12:22am UTC
We are seeing a lot of internal data stores failing right now and are actively working on fixing them.
Affected services